Viewing Requirements | INSTALLATIONS

Frames A Frames-enabled browser (version 3.0+) is required for this tour.
Java Most of the pieces in this exhibit require that JavaScript be enabled in your browser's preferences or options menu.
Get Shockwave! The Shockwave plug-in is required for some of the pieces in this exhibit.
Open the window! Enlarge your browser window to its tallest dimension.
Upgrade! Some pieces in this exhibit will not appear or function properly with older browsers.
Listen Catch the audio—turn up your speakers.
Colors... This exhibit is best viewed with a color setting of thousands.


<Back Enter Exhibit>